请选择 进入手机版 | 继续访问电脑版

SpeedPHP框架

 找回密码
 注册成为新用户

QQ登录

只需一步,快速开始

楼主: starlight36

SpeedPHP验证码扩展类

  [复制链接]
发表于 2014-1-1 16:08:58 | 显示全部楼层
弄了半天验证码不显示,调试了一下午。。。。
最后发现是eregi_repalce报错。估计是php版本的问题吧,原先用没事的。
把104行的eregi_repalce('^#','',$color)改为preg_replace('/^#/', '', $color)就行了。或者改成str_replace杀的都行
发表于 2014-5-28 10:05:23 | 显示全部楼层
$this->vc_session = &$_SESSION[$GLOBALS['G_SP']['sp_app_id']]['verifycode']
发表于 2014-5-28 10:09:53 | 显示全部楼层
$this->vc_session = &$_SESSION[$GLOBALS['G_SP']['sp_app_id']]['verifycode']

这句话没看懂,请大侠指教
发表于 2016-3-3 22:09:40 | 显示全部楼层
感谢分享,感谢分享。
发表于 2016-4-16 13:14:06 | 显示全部楼层
php5.3以上支持有问题啊,即便把eregi_replace改成preg_replace还是有问题,啥也不显示,打开报错,还是一样的,啥报错信息都没有
发表于 2017-7-31 14:13:47 | 显示全部楼层
jake 发表于 2013-4-26 09:01
呵呵,其实不算bug,验证码类是检验验证码是否正确的,

而空值检查,这是一开始要做的,不仅是前端JS要判 ...

想问下,这个不支持5.4以上,否则验证码出错,求解,怎么让他支持PHP高版本
发表于 2017-7-31 14:13:46 | 显示全部楼层
jake 发表于 2013-4-26 09:01
呵呵,其实不算bug,验证码类是检验验证码是否正确的,

而空值检查,这是一开始要做的,不仅是前端JS要判 ...

想问下,这个不支持5.4以上,否则验证码出错,求解,怎么让他支持PHP高版本
您需要登录后才可以回帖 登录 | 注册成为新用户

本版积分规则

手机浏览|简版|中文PHP框架|开源协议|SpeedPHP.com ( 粤ICP备08008671号

GMT+8, 2019-11-23 07:11

Powered by Discuz! X3.2

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表